Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-10171

Migration for ProcessInstances with Incidents are stuck if running asynchronously

    Details

    • Type: Bug Report
    • Status: Closed
    • Priority: L2 - Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 7.10.3, 7.9.11
    • Fix Version/s: None
    • Component/s: cockpit
    • Labels:
    • Title Keywords:
      Migration async incidents

      Description

      What are the steps to reproduce your problem?

      • create a process definition producing an incident
      • deploy it
      • create some process instances of it
      • fix the behavior and deploy again
      • run a migration and check "asynchronously" to do it in batch mode

      What is the problem?

      • the job created above gets stuck
      • if "asynchronously" is not checked the migration runs fine.
        The behavior is reproducible for at least 7.9 and 7.10. In 7.11.0-alpha3 it seems to be fixed.

      What would be the expected behavior:
      The migration job finishes eventually or ends failing.

      Hints (optional):

        Activity

        nikola.koevski Nikola Koevski added a comment - - edited

        Hi Stefan Wiese,

        Can you answer some questions related to how you reproduce the problem:

        1. Are you using one of our pre-configured distributions?
        2. Does this happen with the default configuration?

        Since this is a company support case, can you link it to the appropriate Support ticket?

        Best,
        Nikola

        stefan.wiese Stefan Wiese added a comment -

        Hi Nikola,
        Indeed, I use the pre-configured distribution of wildly-ee with its default configuration. I did not change anything. The same issue was observed by Niall during his last developer training.

        nikola.koevski Nikola Koevski added a comment - - edited

        Hi Stefan,

        Thanks for the fast answer. Since the issue seems to be fixed in 7.11.0-alpha3, we should determine what were the changes that fixed this issue and see if it's possible to backport them to the older versions.

        It would help if you could provide the latest version where this is not working since it would help us narrow down the tickets to inspect. Is this working on 7.11.0-alpha2 (or 7.11.0-alpha1)?

        Also, does the job eventually fail, and if yes, what is the exception?

        Best,
        Nikola

        stefan.wiese Stefan Wiese added a comment -

        The job simply got stuck, no progress (0 % ... ), no exception, nothing to see in the log file. Even after appr. 30 minutes no progress.
        Weird enough, I cannot reproduce this behavior now. I tried several versions, it seems to work now.

        We should close this ticket for now, but I will take observe this in the next time and probably it reappears and I can reproduce it reliably.

        nikola.koevski Nikola Koevski added a comment -

        Thanks for the input. I'll close the ticket now, but if you manage to replicate it consistently, feel free to comment here.

        Best,
        Nikola


          People

          • Assignee:
            nikola.koevski Nikola Koevski
            Reporter:
            stefan.wiese Stefan Wiese
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development