Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-3173

select box doesn't show the correct option

    Details

    • Type: Bug Report
    • Status: Closed
    • Priority: L2 - Critical
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 7.3.0, 7.2.3, 7.3.0-alpha2
    • Component/s: tasklist
    • Labels:
      None

      Description

      If I set the value of variable by a select box on the start form, the next task form didn't show the option that has been choosen in the start form. It uses the same select box.

      I created a small process application to recreate it.
      1. Build and deploy the process application from https://github.com/ingorichtsmeier/ingo-camunda-examples/tree/check-options-test/projects/check-select-boxes (branch check-options-test) to a camunda 7.2.0 tomcat or jboss server.
      2. Login to task list
      3. Start a process instance of check-select-boxes.
      4. Select 'maybe' in the select box 'approved?'
      5. In the next form 'Check the options' the select box should show 'maybe', but it shows 'no'.

      Doublecheck in cockpit shows approved='maybe'.

      If I missed an attribute on the form, please amend the docs.

        Issue Links

          Activity

          gimbel Robert Gimbel added a comment -

          This seems to be a Bug, we schedule the fix for 7.3 and for the 7.2.1 patch (ee only)

          sebastian.stamm Sebastian Stamm added a comment -

          changes in the bpm-sdk-js repository

          sebastian.stamm Sebastian Stamm added a comment -

          works with the latest 7.2.3- and 7.3.0-Snapshots

          alberto.ibanez alberto added a comment -

          This issue seems to happen again from 7.4.0 onwards

          michael.schoettes Michael Schoettes added a comment -

          I can confirm the regression. Therefor I've created CAM-4289. Accordingly I will resolve this ticket and move the discussion to CAM-4289.


            People

            • Assignee:
              michael.schoettes Michael Schoettes
              Reporter:
              ingo.richtsmeier Ingo Richtsmeier
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development