Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-3891

I can inspect a Json or Xml variable instance in Cockpit

    Details

    • Type: Feature Request
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.8.0, 7.8.0-alpha3
    • Component/s: cockpit
    • Labels:

      Description

      The same mechanism like for Bytes and Objects exists for Json (or Xml) variables (which are not mapped to Java objects) in cockpit to inspect the corresponding variable instance

        Issue Links

          Activity

          seif.ghezala Seif Ghezala added a comment -
          • Can inspect/update/add/delete json and xml variables.
          seif.ghezala Seif Ghezala added a comment -
          • I couldn't reproduce the issue you had with adding JSON variable with value {"a": 1}

            .

          • I removed the watcher for variable.value but couldn't make form validation without the watcher for variable.type.
          • DOMParser is now replaced with fast-xml-parser which is compatible for both node and browser.

          Let me know if there is anything that can be enhanced


            People

            • Assignee:
              Unassigned
              Reporter:
              roman.smirnov Smirnov Roman
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development