Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-5005

Recover candidates from historic tasks (IdentityLink)

    Details

    • Type: Feature Request
    • Status: Closed
    • Priority: L2 - Critical
    • Resolution: Fixed
    • Affects Version/s: 7.4.0-alpha2
    • Fix Version/s: 7.5.0, 7.5.0-alpha4
    • Component/s: engine
    • Labels:
      None
    • Title Keywords:
      Candidates IdentityLink

      Description

      AT:

      • cadidate groups can be recovered from history

      We still working with the adaptation of our current application from Activiti to Camunda.
      Our current version is working well except how we can recover the candidates from a finalised task, when it was active.

      In Activiti (5.14) this information is stored in the ACT_HI_IDENTITYLINK table, and can be retrieved via API: historyService.getHistoricIdentityLinksForProcessInstance(processInstanceId)

      However, Camunda didn't provide this method and we are not able to find an equivalent one.

        Issue Links

          Activity

          gimbel Robert Gimbel added a comment -

          Thanks for your input. Am I right, that this is a duplicate of the linked issue?

          If you confirm, I will close this one

          rmondejar Ruben Mondejar added a comment - - edited

          Hi Robert,

          Not exactly duplicated, since we are looking in the same table, the required method and the missing information are different and complementary : assignee (4911) & candidates (5005).

          In my opinion, the best option is to have a more generic issue that includes both cases.

          gimbel Robert Gimbel added a comment -

          I agree, that this should be done at once. For the time being I will leave both issues open.

          Are you interested in providing a pull request on this one?

          rmondejar Ruben Mondejar added a comment -

          I don't have enough knowledge to know why it has disappeared and less to know where is the right place to put this functionality.
          Nevertheless, looking the Activiti code is easy to figure out how to add them :
          A) add a new one (when is needed) : https://github.com/Activiti/Activiti/blob/activiti-5.14/modules/activiti-engine/src/main/java/org/activiti/engine/impl/persistence/entity/ExecutionEntity.java#L1202-L1209
          B) recover them (via Historic API) : https://github.com/Activiti/Activiti/blob/activiti-5.14/modules/activiti-engine/src/main/java/org/activiti/engine/impl/cmd/GetHistoricIdentityLinksForTaskCmd.java#L56-L87

          mabertran Manu Bertran added a comment - - edited

          This table was new in activiti-5.13. As camunda forked activiti-5.12, this table was not present and it seems it has not been added.
          Would be great to add it or at least have the information even stored in another table.


            People

            • Assignee:
              Unassigned
              Reporter:
              rmondejar Ruben Mondejar
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development