Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-7497

As cockpit user, I can see incidents in the process definition view

    Details

    • Type: Feature Request
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.8.0, 7.8.0-alpha4
    • Component/s: cockpit
    • Labels:

      Description

      AT:

      • similar to process instance view I can see incidents in the process definition view
      • an additional incidents tab has to implemented
      • incidents tab is available in runtime and history view
      • it is possible to use filter criteria to qualify the search results

        Issue Links

          Activity

          seif.ghezala Seif Ghezala added a comment -
          • The incidents tab is present in 4 different places, thus there is a new directive that is used to display & control incidents data.
          • As the issue is depending on backend CAM-7820, I will continue the last changes/checks once the backend end point is implemented.
          sebastian.stamm Sebastian Stamm added a comment -
          • filter for incidents is missing
          • incident tab in process definition history is missing. The tab is not part of CAM-7820 yet
          • path comment is wrong in ui/cockpit/client/scripts/directives/incidents-tab.html
          • meaning of jd variable name is not clear in ui/cockpit/client/scripts/pages/processDefinition.js Can we find a better name?
          • debug logging left in code: ui/cockpit/client/scripts/pages/processInstance.js
          • Please try to avoid merge commits by using rebase: https://stackoverflow.com/questions/2472254/when-should-i-use-git-pull-rebase/4675513#4675513
          seif.ghezala Seif Ghezala added a comment -
          • a feature request has been created for the filter component (CAM-8213).
          sebastian.stamm Sebastian Stamm added a comment -

          I cannot find a commit addressing these issues:

          • path comment is wrong in ui/cockpit/client/scripts/directives/incidents-tab.html
          • meaning of jd variable name is not clear in ui/cockpit/client/scripts/pages/processDefinition.js Can we find a better name?
          • debug logging left in code: ui/cockpit/client/scripts/pages/processInstance.js
          seif.ghezala Seif Ghezala added a comment -

          Sebastian Stamm Sorry, I hadn't commit the related changes. They should be there now.

          sebastian.stamm Sebastian Stamm added a comment -

          Looks good. One minor thing: The file location comment now has a different path at the top of the file than at the bottom of the file. But since almost all of these location comments are wrong anyway, I created a ticket to remove them: CAM-8215


            People

            • Assignee:
              Unassigned
              Reporter:
              michael.schoettes Michael Schoettes
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development