Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-7546

Find a better name for deployAndReturnDefinitions

    Details

    • Type: Task
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.7.0
    • Component/s: engine
    • Labels:
      None

      Description

      The new deploy method `DeploymentBuilder#deployAndReturnDefinitions` has a heavy weight name. Maybe we can find a better one.

      Related to this forum post https://forum.camunda.org/t/why-got-deploymentbuilder-deploy-deprecated/3100

        Activity

        Hide
        christopher.zell Christopher Zell added a comment -

        Review:

        • please also rename RepositoryServiceImpl#deployAndReturnDefinitions to #deployWithResult to be consistent
        Show
        christopher.zell Christopher Zell added a comment - Review: please also rename RepositoryServiceImpl#deployAndReturnDefinitions to #deployWithResult to be consistent

          People

          • Assignee:
            Unassigned
            Reporter:
            christopher.zell Christopher Zell
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: