Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-7733

I can't use cockpit with longer breadcrumbs

    Details

    • Type: Bug Report
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.7.0
    • Component/s: cockpit
    • Labels:

      Description

      Steps to reproduce:
      1. Go to deeply nested process instance (process called from process called from process and so on)
      2. Expand breadcrumbs

      Actual:
      You can no longer see all breadcrumbs

      Expected:
      You can see all breadcrumbs.

        Activity

        sebastian.stamm Sebastian Stamm added a comment -

        Is there a reason to use ng-show instead of ng-if? If not, we should use ng-if instead, otherwise, we should document this reason.

        mariusz.sielski Mariusz Sielski added a comment - - edited

        Sebastian Stamm Reason is performance... ng-if removes and adds dome node each time. It is not exactly usable when user can rapidly show and hide elements. For such cases ng-show should be used, as it is the case here. So ng-if there is used for not creating unneeded elements and ng-show is used for hiding and showing elements (possibly quite quickly).

        Similar, but different use case.

        I will add code comment for that later.

        sebastian.stamm Sebastian Stamm added a comment -

        I know this difference I just don't think that clicking fulfills the "rapidly show and hide" criteria to justify using ng-show. To me this looks like an unnecessary optimization that increases complexity (having two attributes instead of one) without supplying enough benefit for it.

        mariusz.sielski Mariusz Sielski added a comment - - edited

        Sebastian Stamm Here I also disagree, as I think it actually helps to avoid complicated condition and separate breadcrumb creation logic (what element should be created) and breadcrumb display logic (what should be shown to user on interaction).

        Also... This is one of the features that invites playing with it a bit, so by all means rapid interaction is case here.

        We can discuss this further if you want, but as for now I see no problem with current solution.


          People

          • Assignee:
            michael.schoettes Michael Schoettes
            Reporter:
            mariusz.sielski Mariusz Sielski
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development