Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-7842

Search Result not visible after using pagination

    Details

    • Type: Bug Report
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: 7.8.0-alpha1
    • Fix Version/s: 7.8.0, 7.7.1, 7.6.7
    • Component/s: cockpit
    • Labels:

      Description

      Reproduce:

      • Perform a search for process instances on Cockpit processes dashboard that returns more than one page of results
      • Go to second page of results
      • Change search query so that it returns only one page of results

      Expected:

      • Search results are displayed

      Observed:

      • Search results are not displayed

      Hint:

      • Internally, the second page of the new query is displayed. Since that is empty due to the changed search, nothing is displayed
      • We should reset the pagination when the search query is changed

        Issue Links

          Activity

          mariusz.sielski Mariusz Sielski added a comment - - edited

          I have created CAM-8011 to move changes to batch operations page, as it is not broken and refactorization would be quite time consuming. It still should be done to avoid code repetition, but code it is working fine, so it can be done later.

          michael.schoettes Michael Schoettes added a comment - - edited

          Does not work on 7.6 for Cockpits Process Instance Search Plugin --> I've created a new issue CAM-8028


            People

            • Assignee:
              michael.schoettes Michael Schoettes
              Reporter:
              sebastian.stamm Sebastian Stamm
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: