Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-7953

Wrong historic variable instance state for variables deleted by engine

    Details

    • Type: Bug Report
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Won't Fix
    • Affects Version/s: 7.8.0-alpha1
    • Fix Version/s: None
    • Component/s: engine
    • Labels:
      None

      Description

      Scenario:

      • process instance with variables in a scope x
      • end scope x

      Expected behavior:

      • historic variables have state DELETED

      Current behavior:

      • historic variables have state CREATED

      Reason:

      • apparently, the deletion state is currently only set when variables are removed explicilty via the remove APIs

        Activity

        roman.smirnov Smirnov Roman added a comment - - edited

        I am closing this, since the state DELETED is used to mark a variable as deleted which has been deleted by a user. Whenever a scope is ended, the variable should not be marked as deleted can stay in the state CREATED.


          People

          • Assignee:
            roman.smirnov Smirnov Roman
            Reporter:
            thorben.lindhauer Thorben Lindhauer
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development