Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-7992

column size of act_ru_authorization.resource_id_ does not match column size of process key

    Details

    • Type: Bug Report
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Duplicate
    • Affects Version/s: 7.7.0
    • Fix Version/s: None
    • Component/s: engine
    • Labels:
      None

      Description

      What are the steps to reproduce your problem?
      Deploy a bpmn process with an Id (Business Key) longer than 64 chars.
      Try to set a specific authorization for this Business Key.

      What is the problem?
      ORA-12899: value too large for column "CAMUNDA"."ACT_RU_AUTHORIZATION"."RESOURCE_ID_" (actual: XXX, maximum: 64)

      What would be the expected behavior:
      Should also accept longer Resource IDs (for example 255 chars as the limitation of KEY_ in ACT_RE_PROCDEF is)

      Hints (optional):
      for Oracle (I didn't check other database DDLs):
      – enlarge column resource_id_ to fit all process keys (remove index while update, Oracle won't accept it otherwise)
      drop index ACT_UNIQ_AUTH_USER;
      drop index ACT_UNIQ_AUTH_GROUP;
      alter table ACT_RU_AUTHORIZATION modify RESOURCE_ID_ NVARCHAR2(255);
      create unique index ACT_UNIQ_AUTH_USER on ACT_RU_AUTHORIZATION
      (case when USER_ID_ is null then null else TYPE_ end,
      case when USER_ID_ is null then null else RESOURCE_TYPE_ end,
      case when USER_ID_ is null then null else RESOURCE_ID_ end,
      case when USER_ID_ is null then null else USER_ID_ end);

      create unique index ACT_UNIQ_AUTH_GROUP on ACT_RU_AUTHORIZATION
      (case when GROUP_ID_ is null then null else TYPE_ end,
      case when GROUP_ID_ is null then null else RESOURCE_TYPE_ end,
      case when GROUP_ID_ is null then null else RESOURCE_ID_ end,
      case when GROUP_ID_ is null then null else GROUP_ID_ end);

      No urgent fix necessary, since we can run the statement already
      But might help others...

        Issue Links

          Activity

          roman.smirnov Smirnov Roman added a comment -

          Hi Jonas,

          Thanks for raising this issue. It has been fixed with CAM-8177 and will be available in the upcoming 7.8.0 release.

          Best,
          Roman


            People

            • Assignee:
              Unassigned
              Reporter:
              jonas.rutishauser@css.ch Jonas Rutishauser
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development