Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-8062

Deployment page broken in Internet Explorer

    Details

      Description

      Reproduce:

      • Goto Deployments page in Cockpit using Internet Explorer (tested with 11)

      Expected:

      • Page is displayed correctly

      Observed:

      • List of Deployments is loaded indefinitely

      Hint:

        Activity

        sebastian.stamm Sebastian Stamm created issue -
        matthijs.burke Matthijs Burke made changes -
        Field Original Value New Value
        Link This issue is depended on by SUPPORT-3506 [ SUPPORT-3506 ]
        matthijs.burke Matthijs Burke made changes -
        Labels SUPPORT
        mariusz.sielski Mariusz Sielski made changes -
        Rank Ranked higher
        matthijs.burke Matthijs Burke made changes -
        Affects Version/s 7.7.1 [ 14896 ]
        matthijs.burke Matthijs Burke made changes -
        Affects Version/s 7.6.7 [ 14899 ]
        roman.smirnov Smirnov Roman made changes -
        Labels SUPPORT EasyPick SUPPORT
        roman.smirnov Smirnov Roman made changes -
        Fix Version/s 7.7.3 [ 14910 ]
        Fix Version/s 7.7.x [ 14699 ]
        roman.smirnov Smirnov Roman made changes -
        Assignee Mariusz Sielski [ mariusz.sielski ] Seif Ghezala [ seif.ghezala ]
        svetlana.dorokhova Svetlana Dorokhova made changes -
        Affects Version/s 7.8.0-alpha2 [ 14906 ]
        roman.smirnov Smirnov Roman made changes -
        Remote Link This issue links to "Page (camunda confluence)" [ 11616 ]
        roman.smirnov Smirnov Roman made changes -
        Rank Ranked lower
        seif.ghezala Seif Ghezala made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        seif.ghezala Seif Ghezala made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Original Estimate 0 minutes [ 0 ]
        Remaining Estimate 0 minutes [ 0 ]
        Fix Version/s 7.6.8 [ 14909 ]
        Fix Version/s 7.6.x [ 14597 ]
        Assignee Seif Ghezala [ seif.ghezala ] Sebastian Stamm [ sebastian.stamm ]
        Resolution Fixed [ 1 ]
        seif.ghezala Seif Ghezala made changes -
        Status Resolved [ 5 ] In Progress [ 3 ]
        seif.ghezala Seif Ghezala made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        sebastian.stamm Sebastian Stamm added a comment -

        I think it makes sense for commons-ui to expose its lodash dependency and for the webapp to require that even for the 7.7 and 7.6 backport. That way we don't run the risk of accidentally using two different versions of lodash.

        Some commits are missing the reference to the ticket. Related commits are:

        sebastian.stamm Sebastian Stamm made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Assignee Sebastian Stamm [ sebastian.stamm ] Seif Ghezala [ seif.ghezala ]
        seif.ghezala Seif Ghezala made changes -
        Status Reopened [ 4 ] In Progress [ 3 ]
        seif.ghezala Seif Ghezala made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Assignee Seif Ghezala [ seif.ghezala ] Sebastian Stamm [ sebastian.stamm ]
        Resolution Fixed [ 1 ]
        sebastian.stamm Sebastian Stamm added a comment -

        Looks like the 7.6 branch of the camunda-bpm-webapp still needs to be updated to use the camunda-commons-ui version. Also, I think we can move lodash back to the dev-dependencies in camunda-bpm-webapp for 7.7. and 7.6

        sebastian.stamm Sebastian Stamm made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Assignee Sebastian Stamm [ sebastian.stamm ] Seif Ghezala [ seif.ghezala ]
        seif.ghezala Seif Ghezala made changes -
        Status Reopened [ 4 ] In Progress [ 3 ]
        seif.ghezala Seif Ghezala added a comment - - edited
        • lodash is now again in devDependencies.
        • 7.6 is already updated to use camunda-commons-ui when requiring lodash.
        seif.ghezala Seif Ghezala made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Assignee Seif Ghezala [ seif.ghezala ] Sebastian Stamm [ sebastian.stamm ]
        Resolution Fixed [ 1 ]
        sebastian.stamm Sebastian Stamm added a comment -

        Show
        sebastian.stamm Sebastian Stamm added a comment -
        sebastian.stamm Sebastian Stamm made changes -
        Status Resolved [ 5 ] In Test [ 10004 ]
        sebastian.stamm Sebastian Stamm made changes -
        Assignee Sebastian Stamm [ sebastian.stamm ] Tassilo Weidner [ tassilo.weidner ]
        tassilo.weidner Tassilo Weidner made changes -
        Status In Test [ 10004 ] Closed [ 6 ]
        tassilo.weidner Tassilo Weidner made changes -
        Assignee Tassilo Weidner [ tassilo.weidner ]
        matthijs.burke Matthijs Burke made changes -
        Link This issue is depended on by SUPPORT-3560 [ SUPPORT-3560 ]
        thorben.lindhauer Thorben Lindhauer made changes -
        Remote Link This issue links to "Page (camunda confluence)" [ 11616 ]
        tassilo.weidner Tassilo Weidner made changes -
        Fix Version/s 7.8.0-alpha3 [ 14907 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            sebastian.stamm Sebastian Stamm
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development