Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-8081

Loading widget does not stop loading on Human Tasks Dashboard in Cockpit

    Details

    • Type: Bug Report
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.8.0, 7.8.0-alpha3
    • Component/s: cockpit
    • Labels:
      None

      Description

      Steps to reproduce:
      1) create a new user in admin
      2) provide access authorization for Cockpit to the new user
      3) login into cockpit with new user in Cockpit

      Problem:
      The backend returns an exception that the user is not allowed to fetch tasks per group. But the loading widget keeps loading (see attached screenshot)

      Expected behavior:

      • stop loading widget
      • The exception is somehow unrelated, so that it is not clear where the problem is. To solve that the exception should not be displayed. Or the message contains more context that is related to "Assignments by group"

        Activity

        seif.ghezala Seif Ghezala added a comment -
        • The loading widget stops now then there is an error.
        • The exception has now more meaningful information.
        sebastian.stamm Sebastian Stamm added a comment -

        I think the error message could make more clear that it is related to the "Assignments by group" section. Right now it more or less just repeats the error status.

        seif.ghezala Seif Ghezala added a comment -

        Sebastian Stamm Is "Unable to fetch assignments by group." fine as an error message? Or should it have more details?

        sebastian.stamm Sebastian Stamm added a comment -

        That should be fine as a message. We should still also display the cause from the server response, i.e. the "User with id "xxx" does not have "READ" permission ..."

        sebastian.stamm Sebastian Stamm added a comment -

        I fixed a linting issue. Can we build something that prevents committing code that does not compile?


          People

          • Assignee:
            Unassigned
            Reporter:
            roman.smirnov Smirnov Roman
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development