Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-8249

In Tasklist I cannot filter for process variables with decimal values

    Details

    • Type: Bug Report
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Cannot Reproduce
    • Affects Version/s: 7.8.0-alpha3
    • Fix Version/s: None
    • Component/s: tasklist
    • Labels:
      None

      Description

      • Reproduce
        Use the Invoice showcase of the prepackaged distribution.
        Add a new Process Variable filter to the list of tasks. Variable Name: Invoice Amount (amount), Operator: = ,Value: 10.99
      • Problem
        Filter result is empty. Even if I change the operator to !=
        The filter does not work for variables with decimal values.

        Activity

        anna.pazola Anna Pazola added a comment -

        This is not a bug. In the 'invoice' process the variable 'amount' becomes a case variable in the step 'review invoice'. It cannot be filtered by Process Variable, but by using Case Variable filter.


          People

          • Assignee:
            anna.pazola Anna Pazola
            Reporter:
            michael.schoettes Michael Schoettes
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development