Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-8577

I can sort list of audit log in case instance

    Details

    • Type: Feature Request
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.9.0, 7.9.0-alpha1
    • Component/s: cockpit
    • Labels:
      None

      Description

      AT:

      • sortable columns: Activity, Start Time, End Time, Activity Instance ID
      • default sorting: Start Time desc

        Activity

        fabian.hinsenkamp Fabian Hinsenkamp created issue -
        fabian.hinsenkamp Fabian Hinsenkamp made changes -
        Field Original Value New Value
        Summary I can sort list of audit log in case definition I can sort list of audit log in case instance
        fabian.hinsenkamp Fabian Hinsenkamp made changes -
        Rank Ranked higher
        roman.smirnov Smirnov Roman made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        roman.smirnov Smirnov Roman made changes -
        Assignee Fabian Hinsenkamp [ fabian.hinsenkamp ] Smirnov Roman [ roman.smirnov ]
        roman.smirnov Smirnov Roman made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Original Estimate 0 minutes [ 0 ]
        Remaining Estimate 0 minutes [ 0 ]
        Assignee Smirnov Roman [ roman.smirnov ] Fabian Hinsenkamp [ fabian.hinsenkamp ]
        Resolution Fixed [ 1 ]
        roman.smirnov Smirnov Roman made changes -
        Description AT:
        - sortable columns: Activity, Start Time, End Time, Activity Instance ID
        - default sorting: Start Time desc
        roman.smirnov Smirnov Roman added a comment - - edited

        Note:

        1. When a case activity instance does not have an activity name then the activity id is shown in Cockpit.
        2. To sort by Activity the sortBy parameter caseActivityName is used.

        If there are two case activity instances:

        • id=1, activityId="foo", activityName="" (there is no activity name defined)
        • id=2, activityId="bar", activityName="Bar"

        When the audit log is ordered by the activity in ascending order, then the table will look like this

        ------------

        Activity ...
        ------------
        foo ...
        ------------
        Bar ...
        ------------

        The problem is that in that case the activity instances without a name are on top. This looks a bit weird.

        Anyway, I decided still to order by name assuming that in the most cases a case activity has a name.

        fabian.hinsenkamp Fabian Hinsenkamp made changes -
        Status Resolved [ 5 ] In Test [ 10004 ]
        fabian.hinsenkamp Fabian Hinsenkamp made changes -
        Assignee Fabian Hinsenkamp [ fabian.hinsenkamp ] Michael Schoettes [ michael.schoettes ]
        michael.schoettes Michael Schoettes made changes -
        Status In Test [ 10004 ] Closed [ 6 ]
        seif.ghezala Seif Ghezala made changes -
        Fix Version/s 7.9.0-alpha1 [ 15191 ]
        fabian.hinsenkamp Fabian Hinsenkamp made changes -
        Affects Version/s 7.9.0-alpha2 [ 15291 ]
        tassilo.weidner Tassilo Weidner made changes -
        Affects Version/s 7.9.0-alpha2 [ 15291 ]
        thorben.lindhauer Thorben Lindhauer made changes -
        Workflow camunda BPM [ 44916 ] Backup_camunda BPM [ 63460 ]

          People

          • Assignee:
            michael.schoettes Michael Schoettes
            Reporter:
            fabian.hinsenkamp Fabian Hinsenkamp
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development