Details

    • Type: Bug Report
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1.0-alpha2, 2.1.0
    • Component/s: backend
    • Labels:
      None

      Description

      Reproduce:

      • create a process instance duration report
      • use this report to configure an alert:
      • set the threshold to a value above the actual value of report and use the "alert if value is below" operation
      • set the check interval to 10 seconds
      • set the reminder interval to 1 minute
      • save the report
      • no new data is imported in this scenario

      Expected:

      • An email is sent every minute

      Observed:

      • An email is sent initially after 10 seconds (check interval)
      • No further email is sent

        Activity

        johannes.heinemann Johannes Heinemann added a comment -

        The problem was that the reminder email was still send, but instead of using the stated unit of the reminder interval to trigger the reminder check, the unit of the check interval was used. If you had waited 10 minutes, you would have received another reminder email.

        johannes.heinemann Johannes Heinemann added a comment -

        Kyrylo Zakurdaiev: the alert code in the backend is pretty nasty. So if you don't understand what is happening here, let's go through the code together.


          People

          • Assignee:
            Unassigned
            Reporter:
            sebastian.stamm Sebastian Stamm
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: