Details

    • Type: Task
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.4.0, 2.4.0-alpha2
    • Component/s: frontend
    • Labels:
      None

      Description

      AT:

      • everywhere I have a search/filter input field in Optimize (e.g. variable filter, group by variable, alert modal, add report modal), the following behavior should be displayed: when we don't have any entries in the list:
        • show only one entry
        • the entry is not selectable
        • it is grayed out
        • the entry has a text saying "No results found." (similar to no-search-results.png)

        Issue Links

          Activity

          Hide
          sebastian.stamm Sebastian Stamm added a comment -

          For the group by variables I decided to just disable to dropdown option if there are no variables. This feels more natural to me than to open a submenu with a disabled input field the user cannot interact with

          Show
          sebastian.stamm Sebastian Stamm added a comment - For the group by variables I decided to just disable to dropdown option if there are no variables. This feels more natural to me than to open a submenu with a disabled input field the user cannot interact with

            People

            • Assignee:
              Unassigned
              Reporter:
              johannes.heinemann Johannes Heinemann
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: