Uploaded image for project: 'Camunda Optimize'
  1. Camunda Optimize
  2. OPT-1757

Server log page for backend shows weird behavior in Firefox

    Details

    • Type: Bug Report
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.4.0
    • Component/s: frontend
    • Labels:
      None

      Description

      • given:
        • I use Firefox
        • I execute yarn run start-backend in the client folder
      • when:
        • I go to the server log page and switch to the Optimize Backend tab
      • then:
        • The output is badly formatted (see start-backend-output.txt)
        • it always scrolls to the start of the logs when new output was added
      • expected:
        • the output is well formatted
        • it automatically scrolls to the end of the logs if new output was added

        Activity

        sebastian.stamm Sebastian Stamm added a comment -

        Johannes Heinemann: I cannot reproduce this. The output looks good to me in Firefox 65.0 on Linux. I removed the auto-scroll feature as part of another commit.

        In order to reproduce this, please provide the first lines of the innerHTML of #backend and provide the frames that are delivered over the websocket (although I think the Firefox dev tools don't show you those yet...)

        Alternatively, we can also have a look at this together.

        johannes.heinemann Johannes Heinemann added a comment -

        I tried to reproduce the problem again and the autoscroll is fixed indeed. However, the bad formatting is still there, but only in the beginning of the output, which is not that important anyway. Therefore, I'll close this ticket for now.


          People

          • Assignee:
            Unassigned
            Reporter:
            johannes.heinemann Johannes Heinemann
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: