Uploaded image for project: 'Camunda Optimize'
  1. Camunda Optimize
  2. OPT-1765

Do not start Optimize if the elasticsearch version does not match

    Details

    • Type: Task
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.4.0, 2.4.0-alpha1
    • Component/s: backend
    • Labels:
      None

      Description

      AT:

      • on startup Optimize retrieves the elasticsearch version via Rest-API and check if this version is actually supported
      • Depending on the ES version Optimize has the following behaviour:
        < 6.2: throw error message that ES version is not supported
        6.2 - 6.5: everything is fine. No log output at all or maybe an info message that Optimize is communicating with ES version 6.X
        > 6.5 but < 7.0: log warning that the version might work, but is not officially supported
        >= 7.0: throw error message that ES version is not supported
      • if the version is not supported Optimize does not start
      • it is documented in the technical guide which versions are supported
      • it easy to add/remove supported versions for a new Optimize version

        Issue Links

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              johannes.heinemann Johannes Heinemann
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: