Uploaded image for project: 'Camunda Optimize'
  1. Camunda Optimize
  2. OPT-1768

DMN Raw Data Report breaks for some DMN tables

    Details

    • Type: Bug Report
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.4.0, 2.4.0-alpha2
    • Component/s: frontend
    • Labels:
      None

      Description

      It seems like the DMN Raw Data Report breaks for some DMN tables.
      In Optimize 2.3.0 I get following error in the UI if I try to create a DMN raw data report:

      Cannot read property 'values' of undefined

      Please see attached screenshots and attached DMN file.

      I suspect this is due to rule 5 which has only one output column, whereas all other rules have two.
      I think it breaks for this output variable.

      1. hiring-manager-assignment.dmn
        3 kB
        Felix Müller
      2. hiring-manager-assignment-working.dmn
        3 kB
        Felix Müller
      3. risk_check_en.dmn
        4 kB
        Felix Müller
      1. Screenshot 2019-01-02 at 13.23.02.png
        85 kB
      2. Screenshot 2019-01-02 at 13.23.09.png
        31 kB

        Issue Links

          Activity

          johannes.heinemann Johannes Heinemann added a comment -

          Felix Müller: I tried to reproduce your problem, but I couldn't. Even with the DMN table you provided everything works fine. So for now I'll just remove the current release label. If this problem shows up again, we can still reuse this ticket. Otherwise I'll just close after the next alpha release.

          johannes.heinemann Johannes Heinemann added a comment -

          Interesting, there really seems to be a bug. Though the error is different than the one you posted here. Can you provide/upload the dmn file here?

          johannes.heinemann Johannes Heinemann added a comment -

          I guess Felix assumption is right here. I'm able to reproduce the error as soon as we have results with different amounts of output columns. Now I'm also able to reproduce it with the hiring assignment and the risk check table.

          sebastian.stamm Sebastian Stamm added a comment -

          I implemented a fix that works for cases where the first instance that is returned contains all output variables. A more robust fix has to be implemented in the backend. I created OPT-1948 for that.


            People

            • Assignee:
              Unassigned
              Reporter:
              felix.mueller Felix Müller
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: