Uploaded image for project: 'Camunda Optimize'
  1. Camunda Optimize
  2. OPT-1619 Refactor Report Updating
  3. OPT-1831

setting process part makes view grey in views that are not process instance duration

    Details

    • Type: Bug Part
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.4.0-alpha1
    • Component/s: frontend
    • Labels:
      None

      Description

      Reproduce:

      • Go to the report builder
      • Select process instance duration view
      • set a process part
      • Change view to something else like frequency of process instance
      • select the group by and visualization
        Expected:
      • View works normally and shows the selected visualization
        Observed:
      • you get a gray screen as shown in the attached picture

        Issue Links

          Activity

          sebastian.stamm Sebastian Stamm added a comment -

          I am not sure how we want to solve this problem. The situation is, that we define a process part and do not reset it when changing the view (in the same way that we do not change the configuration when changing the view). The backend however returns 500 for this request because having a process part does not make sense for this view.

          We have two ways to deal with this:

          • We try to determine when to reset the process part when updating the report in the frontend. That would be inconsistent with how we do it for the visualization configuration, where we keep the fields even if they do not make sense for the current visualization
          • We ignore the process part when evaluating the report, which would maybe make the API harder to understand (I can define a process part but sometimes it is ignored and other times not)

          Johannes Heinemann, Sebastian Bathke, any thoughts?

          johannes.heinemann Johannes Heinemann added a comment -

          Sebastian Stamm: Yes, I do. I think that the process part should be handled like the view, group by and visualization field as it is not part of the configuration field. I do not fully understand why you need to handle the reset of the process part the same way as you do the configuration, but let's have a chat about this.

          sebastian.stamm Sebastian Stamm added a comment -

          We agreed to adjust the parameters field in the frontend when necessary so that the backend only receives valid evaluation requests.


            People

            • Assignee:
              Unassigned
              Reporter:
              omran.abazeed Omran Abazeed
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: