Uploaded image for project: 'Camunda Optimize'
  1. Camunda Optimize
  2. OPT-2183

Bump front-end dependencies to latest version

    Details

    • Type: Task
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.5.0-alpha2
    • Component/s: frontend
    • Labels:
      None

      Description

      AT:

      • all front-end dependencies are updated to the latest version
      • all transitive front-end dependencies are updated to the latest version

      Context:
      It's good practice to use the latest version of libraries because this prevents building developer depths and also ensures that we get the latest security/bug fixes. Also dependabot was not able to catch up with all the necessary updates. Therefore, we should do a clean upgrade once and then let dependabot handle all remaining upgrades.

      Hint:
      There is the command yarn outdated to find out which libraries are outdated and yarn upgrade-interactive to do an upgrade in a controlled manner. However, those commands do not upgrade the transitive libraries.

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            johannes.heinemann Johannes Heinemann
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: