Uploaded image for project: 'Camunda Optimize'
  1. Camunda Optimize
  2. OPT-2290

Remove additional empty space in definition selection popover when no tenant is available

    Details

    • Type: Task
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.5.0
    • Component/s: frontend
    • Labels:

      Description

      AT:

      • the additional empty space in definition selection popover (see too-large-selection-popover.png) is being removed when no tenant is available or there is only one tenant selectable, see here
      • if more then one tenant is available, the process definition selection popover should expand with the tenant select, e.g. see here
      • if a some versions of the process definition contains multiple tenants and some contain only one, then the tenant select is disabled and has the title "--" for all versions where there is only one tenant available

      Context:
      When we added the selection of the tenant to the definition selection, we introduced additional empty space even if a tenant can't be selected. However, the additional introduced empty space is confusing and is actually not needed, since the dropdown for the tenant is hidden anyway.

        Activity

        sebastian.stamm Sebastian Stamm added a comment -

        The empty space was a requirement from product design. We should consult with them to clarify what the expected behavior and look is.

        johannes.heinemann Johannes Heinemann added a comment -

        Noticed! Thanks for the hint. I'll clarify that with Felix and the product design team.

        johannes.heinemann Johannes Heinemann added a comment -

        Great thanks for the input


          People

          • Assignee:
            Unassigned
            Reporter:
            johannes.heinemann Johannes Heinemann
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: