Uploaded image for project: 'Camunda Optimize'
  1. Camunda Optimize
  2. OPT-2339

Optimize upgrade does not perform version checks

    Details

    • Type: Bug Report
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: 2.3.0, 2.4.0
    • Fix Version/s: 2.5.0
    • Component/s: backend
    • Labels:

      Description

      Problem description:

      • given:
        • I have an older version of Optimize running (e.g. 2.4.0) with Elasticsearch 6.0 and an engine version 7.10
        • I stop Optimize
      • when:
        • I run the upgrade script
      • then:
        • the upgrade script is being executed and potentially crashes because it can't cope with the old Elasticsearch version
      • expected:
        • the upgrade script is not being executed
        • I see a log output telling me that the Elasticsearch version is not supported
      • such that:
        • I'm as a user am being prevented from demolishing the optimize elasticsearch schema

        Activity

        Hide
        michael.wagner Michael Wagner added a comment -

        am I understanding it correctly that only the ES version needs to be checked for the upgrade?
        I don't see how the engine version would be relevant here, or am I missing something?

        Show
        michael.wagner Michael Wagner added a comment - am I understanding it correctly that only the ES version needs to be checked for the upgrade? I don't see how the engine version would be relevant here, or am I missing something?
        Hide
        johannes.heinemann Johannes Heinemann added a comment -

        You're right. Let's adjust the ticket!

        Show
        johannes.heinemann Johannes Heinemann added a comment - You're right. Let's adjust the ticket!
        Hide
        sebastian.stamm Sebastian Stamm added a comment -

        Looks like the github review went through and the code is merged, so I am closing this ticket

        Show
        sebastian.stamm Sebastian Stamm added a comment - Looks like the github review went through and the code is merged, so I am closing this ticket

          People

          • Assignee:
            Unassigned
            Reporter:
            johannes.heinemann Johannes Heinemann
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: