Uploaded image for project: 'Camunda Optimize'
  1. Camunda Optimize
  2. OPT-903

Add hover interaction between Statistics and Diagram

    Details

    • Type: Feature Request
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.0-alpha1, 2.2.0
    • Component/s: frontend
    • Labels:
      None

      Description

      AT:

      • When hovering over a bar in the Statistics section in the Branch Analysis the corresponding sequence flow in the bpmn diagram are highlighted (similar to the branch analysis in optimize 1.x)

        Issue Links

          Activity

          sebastian.stamm Sebastian Stamm added a comment -
          • When selecting some gateways and the hovering over the bars, it crashes. You can reproduce this with the Lead Qualification process, end event Lead is Opp and Gateway New Lead. The sequence flow is then undefined in Statistics.js:158. Probably caused by the fact that not all sequence flows have names.
          • I think the viewer should not be a state variable, but an instance variable in the Analysis component. This would prevent the unnecessary component update when it is set
          • Why is setViewer called for every element instead of only once in the componentDidMount method of DiagramBehavior?
          • Do we want to have tests?
          sebastian.stamm Sebastian Stamm added a comment -
          • Why do we need the isHover variable? I think it is not needed, but I may be missing something. In that case, I would call it isHovering instead
          • I think the HoveredElementLabel constant in the markSequenceFlow method in the Statistics class should not be upper case.
          omran.abazeed Omran Abazeed added a comment -
          • Regarding the IsHover variable: it is needed because hover callback is called on every mouse move and it is only needed to know when the mouse enters one of the chart boxes or gets out of it.
            If the variable is removed the makeSequenceFlow function will be called on every mouse move even inside the chart box
            I changed the name to isInside instead of IsHover for more clarity
          • Good catch for variable name

            People

            • Assignee:
              Unassigned
              Reporter:
              sebastian.stamm Sebastian Stamm
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: