[CAM-8062] Deployment page broken in Internet Explorer Created: 24/Jul/17  Updated: 30/Aug/17  Resolved: 02/Aug/17

Status: Closed
Project: camunda BPM
Component/s: cockpit
Affects Version/s: 7.7.1, 7.6.7, 7.8.0-alpha2
Fix Version/s: 7.8.0, 7.8.0-alpha3, 7.6.8, 7.7.3

Type: Bug Report Priority: L3 - Default
Reporter: Sebastian Stamm Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: EasyPick, SUPPORT
Remaining Estimate: 0 minutes
Time Spent: Not Specified
Original Estimate: 0 minutes

Issue Links:
Depedendency

 Description   

Reproduce:

  • Goto Deployments page in Cockpit using Internet Explorer (tested with 11)

Expected:

  • Page is displayed correctly

Observed:

  • List of Deployments is loaded indefinitely

Hint:



 Comments   
Comment by Sebastian Stamm [ 02/Aug/17 ]

I think it makes sense for commons-ui to expose its lodash dependency and for the webapp to require that even for the 7.7 and 7.6 backport. That way we don't run the risk of accidentally using two different versions of lodash.

Some commits are missing the reference to the ticket. Related commits are:

Comment by Sebastian Stamm [ 02/Aug/17 ]

Looks like the 7.6 branch of the camunda-bpm-webapp still needs to be updated to use the camunda-commons-ui version. Also, I think we can move lodash back to the dev-dependencies in camunda-bpm-webapp for 7.7. and 7.6

Comment by Seif Ghezala [ 02/Aug/17 ]
  • lodash is now again in devDependencies.
  • 7.6 is already updated to use camunda-commons-ui when requiring lodash.
Comment by Sebastian Stamm [ 03/Aug/17 ]

Generated at Wed Sep 20 04:10:12 CEST 2017 using JIRA 6.4.6#64021-sha1:33e5b454af4594f54560ac233c30a6e00459507e.