[OPT-1287] Flow Node Filter does not show diagram in branch analysis Created: 21/Jun/18  Updated: 18/Apr/19  Resolved: 03/Jul/18

Status: Done
Project: Camunda Optimize
Component/s: frontend
Affects Version/s: None
Fix Version/s: 2.2.0-alpha1, 2.2.0

Type: Bug Report Priority: L3 - Default
Reporter: Michael Schoettes Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified


 Description   

Reproduce

  • Create a new Branch Analysis by clicking on the analysis tab
  • Select a process definition
  • Select Add Filter
  • Select the Flow Node Filter

Problem

  • A Flow Node filter does not show the process definition model like it is done in the report builder

Expected Behavior

  • The Flow Node Filter shows also in the branch analysis the process definition xml


 Comments   
Comment by Omran Abazeed [ 03/Jul/18 ]

Can you please check and let me know.

Thanks

Comment by Sebastian Stamm [ 03/Jul/18 ]

Works great! I like that you added a test. Two minor remarks:

  • We should remove the console.log statement in the test
  • I think the name of the test can be a bit more accurate. We are not testing that the filter shows the diagram, we just test that we pass the property. Something like it('should pass the xml to the Filter component') is more fitting in my opinion
Comment by Omran Abazeed [ 03/Jul/18 ]

Yea you are right, I did the changes. Please have a look.

Thanks

Comment by Sebastian Stamm [ 03/Jul/18 ]

Great work!

Generated at Mon Jul 15 22:11:02 CEST 2019 using JIRA 6.4.6#64021-sha1:33e5b454af4594f54560ac233c30a6e00459507e.